您應該安裝未經WordPress版本測試的插件嗎?


我們的用戶經常向我們詢問有關未使用其WordPress版本測試插件的警告。 您應該安裝該插件的插件嗎? 或找到另一個插件? 在本文中,我們將討論為什麼您應該安裝未經WordPress版本測試的插件? 這是什麼意思,以及如何幫助WordPress社區?

當您從WordPress管理區域安裝插件時,您可能會看到一條警告,提示您的WordPress版本未經過測試。

插件兼容性警告

WordPress如何獲取未經測試的信息?

官方WordPress插件存儲庫是最大的免費和開源WordPress插件集合。 提交插件時,要求作者與他們的插件一起提交“自述文件”。 然後,插件目錄使用此自述文件來生成插件頁面。

自述文件包含 “經過測試” 用於顯示信息的標籤。 插件作者應保持此信息為最新。

這意味著在每個WordPress版本中,插件作者都應測試其插件並更新其插件的自述文件。

為什麼插件作者不更新此信息?

即使使用最新版本測試插件,許多插件作者也根本不會更新其自述文件。

在理想的情況下,我們希望所有插件作者都可以更新此信息。 但是我們沒有生活在理想的世界中。

請記住,這些插件是免費的,您無需付費就可以下載和使用它們。 插件作者不太願意在每個發行版中更新自述文件。 他們通常忙於全職工作和有償開發項目。

影片教學

訂閱WPBeginner

如果您不喜歡該視頻或需要更多說明,請繼續閱讀。

我應該安裝這些插件嗎?

是的你應該。 僅僅是因為插件作者沒有更新其自述文件,並不意味著他們尚未測試其插件或該插件不適用於最新版本的WordPress。

如果您聽說過WPBeginner上的插件,那麼可以放心地假設我們已經使用最新版本的WordPress測試了該插件。 如果您正在查看的文章是最近才發布的,則表明該插件與WordPress的最新版本兼容。

另一方面,如果插件未更新兩年以上,則意味著該插件很可能已被放棄。 在這種情況下,您不應該安裝插件。

有趣的是,許多未更新兩年以上的插件實際上仍然運行良好。 但是,應自行承擔安裝風險。

您將如何提供幫助?

您可以在WordPress網站上安裝插件並進行測試。 如果可以正常工作,請返回插件頁面。 使用您的WordPress.org用戶名和密碼登錄。 接下來,向下滾動到頁面底部,您將在其中看到兼容性部分。

投票支持插件兼容性

只需選擇您的WordPress版本,插件版本,然後單擊“作品”按鈕。 這樣,您就可以讓其他用戶知道您已經測試了插件,並且可以按承諾工作。

您也可以聯繫插件作者,並請他們更新其插件的自述文件

插件損壞時該怎麼辦?

我們再次提醒用戶,如果它是免費的插件,則插件作者已按原樣提供了它。 沒有保修,甚至沒有暗示的適用性保修。 但是問題是,您如何才能幫助社區處理損壞的插件?

您可以在建設性的,有用的反饋中留下意見,而不必在插件的支持線程上留下苛刻的評論。 請參閱我們的指南,了解如何正確地獲得WordPress支持並獲得它。

在執行任何操作之前,請嘗試在其他實時或本地WordPress安裝上安裝插件。 確保您也能夠在其他安裝上重現相同的錯誤。

一旦確定插件已損壞,只需在支持線程中描述錯誤,然後將其留給插件作者或社區來響應。 如果沒有收到回應,則可以嘗試與插件作者聯繫。 大多數插件作者在其WordPress.org個人資料頁面上都有聯繫信息。

如果這些步驟失敗,那麼您可以隨時訪問插件頁面,並在兼容性部分下對插件損壞進行投票。

我們希望本文能幫助您回答有關是否應安裝未經WordPress版本測試的插件的問題。

如果您喜歡這篇文章,請訂閱我們的YouTube頻道WordPress視頻教程。 您也可以在找到我們 推特 和Google+。