如何測試您的網站以更新到古登堡(WordPress 5.0)


您對使用新的WordPress Gutenberg編輯器感到興奮嗎? Gutenberg是與WordPress 5.0一起正式啟動的,是WordPress的新默認內容編輯器,它使您可以使用塊創建視覺效果驚人的內容。

挑戰在於某些主題和插件可能無法正確支持Gutenberg,因此更新您的網站可能會導致意外問題。

在本文中,我們將向您展示如何測試WordPress網站以更新到Gutenberg和WordPress 5.0。

測試您的網站以更新到古騰堡和WordPress 5.0

為什麼要在更新到古騰堡之前測試您的WordPress網站?

WordPress 5.0帶來了一種全新的創建內容的方式,即使用名為The Block Editor或Gutenberg的全新編輯器。 它用 這些內容元素可以在編輯器中移動。

新的WordPress區塊編輯器也稱為Gutenberg

帶有Gutenberg編輯器的WordPress 5.0確實是WordPress平台的革命性改進。

但是,由於這種巨大的變化,一些用戶不願意立即更新其網站,因為擔心某些操作將無法正常工作,否則可能會破壞其網站。

古騰堡(Gutenberg)經過長時間的開發,為主題和插件開發人員提供了足夠的時間使其產品與古騰堡兼容。 所有頂級WordPress插件已經與Gutenberg完全兼容,並且大多數主題都可以正常工作。

但是,為避免任何衝突,您可能需要使用Gutenberg和WordPress 5.0測試您的網站。 這將使您查找是否有任何插件或主題不兼容。 您還可以捕獲意外錯誤,並在更新實時站點之前修復它們。

話雖如此,現在讓我們繼續並檢查如何逐步測試您的網站以更新到Gutenberg或WordPress 5.0。

步驟1:建立網站的完整備份

在進行任何重大更新之前,您必須始終創建WordPress網站的完整背面。 備份可保護您免受更新過程中可能發生的任何不幸損壞。

即使您不更新網站,保持定期的網站備份也很重要,因為這樣可以在災難性情況(例如惡意軟件攻擊,黑客攻擊等)中為您省錢。

有很多WordPress備份插件可供選擇。 我們建議使用UpdraftPlus,因為它允許您設置自動備份並將其存儲在遠程位置。

步驟2:在本地服務器或登台站點上測試您的站點

創建完網站的完整備份之後,現在就可以使用WordPress 5.0和新的Gutenberg編輯器來測試您的網站了。

有兩種常用方法可以測試新更新,而又不會真正影響您的實時站點。

  1. 在計算機上安裝的本地服務器上測試您的網站
  2. 在登台服務器上測試您的網站

這兩個選項均允許您使用新的Gutenberg編輯器以及現有內容,插件和主題來測試WordPress 5.0。

1.在本地服務器上測試您的網站

使用本地服務器只是意味著要使用WAMP或MAMP(適用於Mac)之類的軟件在個人計算機上安裝WordPress網站。

在這種方法中,您將首先使用Duplicator等遷移插件將實時WordPress網站的副本移動到本地服務器。

複製器WordPress插件

然後,在本地站點上,您可以更新到WordPress 5.0並測試所有插件/主題與新編輯器的兼容性。

您還可以在本地站點上進行更改,並在完成後將其上載到實時站點。

如果您不需要對本地站點進行任何更改,並且一切看起來都不錯,那麼您可以繼續將實時站點更新為WordPress 5.0。

2.在登台環境中測試您的網站

登台網站是網站的獨立開發版本,您可以在其中試用新功能。

它通常是您網站的子域,受到公共訪問的限制。 在這裡,您可以測試新的更新,主題,插件,或將其用於所有開發。 測試完所有必要的內容後,您可以將其上傳到實時站點。

大多數頂級WordPress託管公司都會從您的託管帳戶中提供一鍵式登台站點安裝。

如果您的站點由Bluehost託管,則可以在WordPress管理儀表板的Bluehost菜單下找到一個創建臨時站點的選項。

在Bluehost中創建登台站點

您還可以在WPEngine和SiteGround上創建一鍵式登台站點。 如果您沒有使用這些託管公司中的任何一家,則應詢問您的託管人,因為它們可能提供此功能。

如果您的託管服務沒有暫存站點安裝功能,那麼您仍然可以自己手動進行。 這是關於如何在WordPress中創建過渡環境的分步教程。

步驟3:安裝經典編輯器插件

WordPress 5.0中最重要的變化是新的Gutenberg編輯器。

這意味著,如果您遇到任何問題,則很可能是由插件或主題與新編輯器不兼容引起的。

您也可能不喜歡新的編輯器。

幸運的是,您可以更新到WordPress 5.0,並且仍然保留經典的WordPress編輯器。

您只需在WordPress網站上安裝經典編輯器插件即可禁用古騰堡。 這樣做可以讓您安全地更新到WordPress 5.0,同時仍保留您熟悉的經典編輯器。

切換到經典編輯器

經典編輯器是WordPress核心貢獻者提供的官方WordPress插件,可讓您切換回經典編輯器。 使用此插件,您可以像以前一樣隱藏Gutenberg編輯器並創建內容。

如果由於主題或插件在更新到WordPress 5.0後無法正常工作而不得不安裝Classic Editor,那麼您仍有工作要做。

您需要聯繫主題或插件開發人員,並要求他們使其與最新的WordPress版本兼容。

如果您沒有得到積極的回應,則需要找到替代主題或插件來替換不兼容的主題或插件。

第4步。在WordPress 5.0+中更新到Gutenberg之後要做的事情

如果您只是開始第一個WordPress博客,那麼您很幸運。 您將很快習慣於功能強大的新塊編輯器,該編輯器更快,更現代且功能強大。

另一方面,如果您已經使用WordPress一段時間了,那麼新的編輯器將為您帶來令人興奮的新體驗。

我們大多數人習慣於使用舊的編輯器,並圍繞它進行設置。

好消息是,您仍然可以使用Gutenberg來完成您在舊編輯器中所做的所有工作,然後再執行其他工作。

為了幫助您學習新功能,我們創建了完整的Gutenberg教程,該教程顯示瞭如何使用新的塊編輯器以及如何為您的站點創建視覺上令人驚嘆的內容。

我們希望本文能幫助您學習如何測試WordPress網站以更新到Gutenberg或WordPress 5.0。 要對您可能遇到的常見錯誤進行故障排除,請查看有關最常見的WordPress錯誤及其修復方法的指南。

如果您喜歡這篇文章,請訂閱我們的YouTube頻道WordPress視頻教程。 您也可以在找到我們 推特 和Facebook。