WordPress 2.8.1正式發布


WordPress 2.8.1已正式發布,由Ryan在WordPress博客上發布。 這個版本有兩個測試版和多個補丁,直到今天終於發布。

WordPress 2.8.1修復了許多錯誤,並提高了插件管理頁面的安全性。 在以前的版本中,非特權用戶可以查看某些插件添加的管理頁面,從而導致信息洩漏。 並非所有插件都容易受到此問題的影響,但是WordPress工作人員和WPBeginner建議您安全升級到2.8.1。

WordPress 2.8.1中進行了大量更改,我們將在此處列出一些突出顯示的內容,但是如果您願意,可以查看完整列表。

  • 某些主題以一種在2.8中失敗的方式調用get_categories()。 2.8.1可以解決此問題,因此這些主題無需更改。
  • 儀表板內存使用量減少了。 加載儀表板時,有些人內存不足,導致頁面不完整。
  • 從失敗的升級清除時,自動升級不再會意外刪除文件。
  • 解決了由於壓縮問題而無法加載RTF編輯器的問題。
  • 額外的安全性已到位,可以更好地保護您免受那些未進行明確權限檢查的插件的侵害。
  • 角色名稱的翻譯固定。
  • wp_page_menu()默認為按用戶指定的菜單順序而不是頁面標題進行排序。
  • 現在可以正確報告上傳錯誤消息。
  • 某些IE用戶遇到的自動保存錯誤已修復。
  • 修正了插件編輯器中的樣式錯誤。
  • SSH2文件系統要求已更新。
  • 切換回curl作為默認傳輸方式。
  • 更新了翻譯庫以避免mbstring.func_overload出現問題。
  • 更嚴格的內聯樣式消毒。
  • 更嚴格的菜單安全性。
  • 由於瀏覽器不兼容,禁用了代碼突出顯示。
  • RTL佈局修復。

現在,如果您選擇升級,我們強烈建議您這樣做,那麼您可以一鍵升級WordPress現在擁有的升級。 大多數用戶應該已經在wp-admin面板頂部看到一個欄,要求您進行升級。

單擊升級按鈕,然後按照步驟進行。 如果要下載計算機的副本,請轉到WordPress下載。