您的虛擬主機的PHP更新如何影響您的WordPress網站


最近,我們的一位用戶與我們聯繫,告知他們從託管服務提供商處收到的有關升級到新版本PHP的通知。

WordPress是用PHP編程語言編寫的。 它是一種服務器端語言,這意味著它可以在您的網絡託管服務器上運行以動態生成WordPress頁面。

在本文中,我們將解釋您的Web主機進行的PHP更新如何影響您的WordPress網站。 我們還將討論您可以採取的措施,以避免網站上的任何衝突或停機。

您的Web主機進行的PHP更新應該可以順利進行,但也可能會出錯。 這完全取決於您的Web主機以及它們如何配置服務器。

這就是為什麼我們建議用戶選擇最好的WordPress託管,因此他們知道有頂尖的工程師來照顧這些服務器。

為WordPress網站選擇不可靠的Web主機可能會導致更新期間或更新後出現意外停機,除了切換到更好的主機之外,您幾乎無能為力。

WordPress和PHP更新

WordPress是使用開放源代碼編程語言PHP開發的。 在撰寫本文時,WordPress至少需要PHP 5.6.20或更高版本。 當前可用於PHP的穩定版本是7.3.8。

大多數共享主機提供商當前都提供在其服務器上安裝的PHP 7.0。+版本。

某些網絡主機甚至可能允許您從其控制面板更改PHP版本。 不使用網絡主機使用最新技術和最新穩定版本的PHP有多種原因,但是最常見的原因是,最新版本有時會破壞某些PHP應用程序。

但是,他們也不想落後。 目前最低要求版本為PHP 5.6。+,通常建議使用php 7.0+。

主機更新PHP時需要做的事情

您的網絡託管商可能已經託管了數千個WordPress網站。 他們將竭盡所能,以確保一切順利,客戶在服務中不會感到任何毛刺。

收到的通知可讓您了解有關更新的信息,並隨時檢查是否有任何問題。 儘管此更新不太可能破壞事情,但最好有一個後備計劃。

首先,我們始終建議用戶定期備份WordPress網站。 如果您沒有像BackupBuddy,VaultPress或BackWPup這樣的自動備份解決方案,那麼現在是時候安裝其中一個或至少創建網站的手動備份的時候了。

備份後,接下來要做的就是確保您正在運行最新版本的WordPress。 另外,請確保您所有的插件和主題都是最新的。

轉到更新屏幕並安裝所有可用更新。

WordPress本身和大多數流行的WordPress插件都不會受到PHP更新的影響。 但是,某些插件可能會停止工作。

如果您的站點上的插件由於PHP更新而停止工作,那麼您需要聯繫插件作者以尋求支持或尋求替代方法。

如果PHP更新破壞了WordPress網站怎麼辦?

PHP更新破壞您的WordPress網站的可能性很小。 但是,由於有大量的免費插件和付費插件,單行不良代碼可能導致錯誤。

您需要做的第一件事是確保它不是導致此錯誤的插件或主題。 為此,請停用所有WordPress插件並切換到默認WordPress主題。

如果這不能解決您的問題,請與您的虛擬主機的支持團隊聯繫。 您面臨的問題很可能已經在他們的通知中,他們將能夠為您提供幫助。

如果您的虛擬主機無法幫助您,請嘗試安裝WordPress的新副本,然後從備份中還原WordPress網站。

如果以上方法均無濟於事,那麼也許該是更改WordPress託管的時候了。

我們希望本指南可以幫助您了解網站託管商的PHP更新如何影響WordPress網站。 對於反饋和問題,請在下面發表評論。